Fabian Hueske created FLINK-18298:
-------------------------------------
Summary: Rename TableResult headers of SHOW statements
Key: FLINK-18298
URL:
https://issues.apache.org/jira/browse/FLINK-18298 Project: Flink
Issue Type: Improvement
Components: Table SQL / API
Affects Versions: 1.11.0
Reporter: Fabian Hueske
The SHOW TABLES and SHOW FUNCTIONS commands are listing all tables and functions of the currently selected database.
With FLIP-84, the result is passed back as a TableResult object, that includes the schema of the result as a TableSchema.
The column name for the result of SHOW TABLES and SHOW FUNCTION is "result":
{code:java}
SHOW TABLES;
result
myTable1
myTable2
{code}
I think this name is not very descriptive and too generic.
IMO it would be nice to change it to "table name" and "function name", respectively.
{code:java}
SHOW TABLES;
table names
myTable1
myTable2{code}
Would be nice to get this little improvement in before the 1.11 release.
cc [~godfreyhe], [~twalthr]
--
This message was sent by Atlassian Jira
(v8.3.4#803005)