Liya Fan created FLINK-13200:
--------------------------------
Summary: Improve the generated code for if statements
Key: FLINK-13200
URL:
https://issues.apache.org/jira/browse/FLINK-13200 Project: Flink
Issue Type: Improvement
Components: Table SQL / Planner
Reporter: Liya Fan
Assignee: Liya Fan
In the generated code, we often code snippet like this:
if (true) {
acc$6.setNullAt(1);
} else {
acc$6.setField(1, ((int) -1));;
}
Such code impacts the code readability, and increases the code size, making it more costly for compiling and transferring through network.
In this issue, we remove such useless if conditions.
--
This message was sent by Atlassian JIRA
(v7.6.3#76005)